本文へ移動

#CVE-2026-109383

脆弱性の一覧へ戻る

編集部の見出し:undici(Node.js の HTTP クライアント、HTTP/2 上の WebSocket で処理が落ちる)

CVE(NVD)CVSS 9.1 CriticalEPSS 0.2%

NVD の情報

undici is an HTTP client library for Node.js. In versions 4.0.0 through 6.29.0, 7.0.0 through 7.30.0, and 8.0.0 through 8.12.1, its Agent dispatcher passes its constructor options through a JSON-based deep clone before forwarding them to each per-origin pool, and because JSON cannot represent functions, a caller-supplied tls option containing a checkServerIdentity callback is silently dropped before it reaches the TLS layer. As a result, a TLS peer whose certificate a custom checkServerIdentity was written to reject, but which passes Node's default hostname and chain checks, is silently accepted. Because Agent is the default dispatcher behind request, fetch, and setGlobalDispatcher, this affects the path most applications use, and EnvHttpProxyAgent is affected on its direct and no-proxy routes as well, while only applications that pass a function-valued tls option such as a custom checkServerIdentity for certificate or public-key pinning are at risk. The issue is fixed in undici 6.29.1, 7.30.1, and 8.12.2, which preserve the tls option outside the JSON clone so custom verification callbacks are forwarded unchanged, and users should upgrade to one of those versions or later. As a workaround, pass the TLS options through connect instead of tls, or for proxied destinations use requestTls and proxyTls.

公開日
2026-10-15
最終更新(NVD)
2026-10-19
NVD の状態
Analyzed
脆弱性の種類
CWE-295

深刻度(CVSS)

  • 7.4 HighCVSS 3.1/副/評価:ce714d77-add3-4f53-aff5-83d477b104bbCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
  • 9.1 CriticalCVSS 3.1/主/評価:nvd@nist.govCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

悪用の状況

CISA KEV には掲載されていません(掲載されていないことは、悪用されていないことの証明ではありません)。

EPSS:今後30日に悪用される推定確率 0.18%(全体の上位 92.0%、評価日 2026-10-30)

解消方法

  • nodejs undici のバージョンアップ6.29.1 以上、7.30.1 以上、8.12.2 以上根拠:NVD の条件から推定

「NVD の条件から推定」は、NVD が影響ありとする版の上限から読み取ったもので、修正版とは限りません。「解消方法の情報なし」は、修正が無いという意味ではありません。必ずベンダーの公告で確認してください。

影響を受ける製品と版(NVD の条件)

版の範囲は NVD の条件上の影響範囲です。修正版とは限りません。修正版はベンダーの公告で確認してください。

  • nodejs undici:4.0.0 以上、6.29.1 未満限定:targetSw=node.js
  • nodejs undici:7.0.0 以上、7.30.1 未満限定:targetSw=node.js
  • nodejs undici:8.0.0 以上、8.12.2 未満限定:targetSw=node.js

編集部の記載(レポート掲載時)

レポートの編集部がベンダー公告などから転記した内容です。検証済みの値ではないため、必ず出典で確認してください。

参照(NVD)

NVD から取得:2026-10-30T18:10:17.960Z/EPSS 評価日:2026-10-30

This product uses the NVD API but is not endorsed or certified by the NVD.

悪用の確認情報は CISA Known Exploited Vulnerabilities Catalog(NVD 経由で取得)によります。EPSS は FIRST(www.first.org/epss)によります。